Skocz do zawartości
TajnyAgent

Problem z instalacją firmware'u/usunięciem root'a

    Rekomendowane odpowiedzi

    Witam.

     

    A więc zacznę od początku. Wyciągnąłem wczoraj swój stary Tablet Prestigio MultiPad 8.0 HD PMT5587_Wi w celu zainstalowania snapchat'a oraz modułu SnapPrefs. Z początku męczyłem się z uruchomieniem samego tableta i naprawianiem ładowania, ale w końcu się udało. Po uruchomieniu tableta, przez ES File Explorer włączyłem serwer zdalny i z poziomu komputera przerzuciłem sobie wszystkie dane na komputer(backup). Zauważyłem szybko, że waga danych różni się z rzeczywistym zajęciem pamięci na tablecie, później doszedłem do tego, że nie ma łatwego dostępu do całego systemu i jego danych(tak, jestem laikiem), a to co przerzuciłem z tabletu na komputer to jedynie część danych.

    Niemniej jednak po przerzuceniu tych danych na komputer postanowiłem przywrócić ustawienia fabryczne poprzez tryb Recovery, po zrobieniu tego skonfigurowałem tableta i przeszedłem do procesu root'owania. Root także robiłem pierwszy raz, więc nie spędziłem specjalnie dużo czasu na przygotowaniach, natknąłem się na początku na KingRoot, ale z przeczytanego artykułu o nim wynikło, że nie będzie on dobry do mojego tableta. Chwilę później natknąłem się na iRoot, był z tym mały problem, ale generalnie wszystko szybko udało się ogarnąć i zakończyło się to zroot'owaniem tableta. Niestety iRoot instaluje przy tym jakieś chińskie app'ki i musiałem je zaraz pousuwać, jak się później okazało to mimo usunięcia tych app'ek wyświetlają mi się jakieś reklamy, a po jakimś czasie używania tableta samoczynnie instaluje mi się jakaś app'ka z News'ami, zauważalny był także spadek wydajności.

    Niemniej jednak przystąpiłem do procesu zainstalowania SnapChat'a, framework'a xPosed oraz modułu SnapPrefs. Jak się później okazało, to w złej kolejności próbowałem się zalogować do SnapChat'a przez co SC wykrywał SnapPrefs, więc odinstalowałem SnapPrefs i wtedy zdecydowałem się zalogować do SC, ale ku mojemu zdziwieniu SnapChat przy weryfikowaniu urządzenia dalej wykrywał Third-Party Apps. Więc postanowiłem znowu przywrócić tablet do ustawień fabrycznych. Niestety po zrobieniu tego okazało się, że root na tablecie nadal jest i po chwili ponownego korzystania z tableta instaluje się app'ka z News'ami o której wcześniej napisałem oraz, jak przyuważyłem to jest zainstalowana aplikacja KingRoot(to mnie zdziwiło, wygląda na to, że iRoot instaluje także KingRoot), no ale kwestia tego, że root nadal jest, a SC dalej wykrywa Third-Party Apps. Próbowałem po tym wszystkim zainstalować od nowa FirmWare, ściągnąłem najnowsza wersję ze strony producenta, wgrałem na kartę pamięci, odpaliłem tryb Recovery, zrobiłem wipe data i wipe cache. Niestety przy instalacji wyskakuje "Instalation Aborted".

     

    No i podsumowując sytuacja aktualnie wygląda tak, że nie jestem do końca pewien co robić, dodam jeszcze, że niby probowałem unroot'ować tablet'a z poziomu iRoot i niby unRoot'uje tego tablet'a, ale tak jakby nie do końca. Chciałbym wgrać od nowa czysty ROM od Prestigio(FirmWare to chyba to samo(?) i na nowo zRoot'ować telefon w może jakiś czystszy sposób, tyle że nie wiem jak to zrobić poczynając od samej instalacji czystego FirmWare'u. Pogubiłem się trochę w tym wszystkim, dlatego też powstał ten temat, z góry dziękuję za pomoc :)

     

    P.S. Przepraszam także jeżeli temat został napisany nieco chaotycznie, ale starałem się całą 2-dniową pracę nad tablet'em skrócić do najważniejszych szczegółów.

    dodana zawartość

    Wydaję się, że problem został rozwiązany. Postanowiłem zainstalować na PC KingRoot i jeszcze raz zroot'ować tableta, tylko tym razem poprzez KingRoot. Udało się i zaraz z poziomu KingRoot unroot'owałem tableta. Po formacie tableta już nie było aplikacji KingRoot oraz zniknęły reklamy, jak i samoinstalującą się news'owa aplikacja.

    Niestety wciąż musiały być jakieś pozostałości po zroot'owaniu poprzez iRoot, więc poszperałem trochę jeżeli chodzi o reinstalację firmware'u i doszedłem do tego, że nie wypakowałem paczki update.zip z paczki, którą pobrałem od producenta. Sądziłem, że pobrana paczka już jest tym samym firmware'm. Po wypakowaniu update.zip z pobranej paczki ze strony producenta i wrzuceniu na kartę SD bez problemu zreinstalowałem firmware co ostatecznie rozwiązało problem z wykrywaniem Thirdy-Part Apps przez SnapChat'a.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Ostatnio przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.

    x