Skocz do zawartości
paveu241

mod [Oreo][Systemless] Instalacja Xposed dla Oreo

    Rekomendowane odpowiedzi

    paveu241

    NIE BIORĘ ODPOWIEDZIALNOŚCI ZA USZKODZENIA TELEFONU.

    WSZYSTKO ROBISZ NA WŁASNĄ ODPOWIEDZIALNOŚĆ!!!

    WYMAGANY MAGISK.

     

    W poniższym poradniku zaprezentuję szybki sposób na zainstalowanie bety Xposed na Oreo (ze styczniowymi poprawkami).

     

    • Wymagania:
      • Telefon
      • Dostęp do internetu
      • Root za pomocą Magisk - procedurę wykonałem na wersji 15.3.

     

    JEŚLI NIE WIESZ JAK W PRZYPADKU BOOTLOOPA ODINSTALOWAĆ MAGISKA - NIE INSTALUJ XPOSED!

    PO INSTALACJI XPOSED TELEFON NIE PRZEJDZIE SAFETYNET!

     

    Do rzeczy.

    1. Pobieramy i instalujemy zmodyfikowaną wersję Xposed Installer.
    2. Otwieramy Magisk Manager.
    3. W zakładce Pobieranie wybieramy Xposed Framework (SDK 26).
    4. Instalujemy go jak każdy inny moduł.
    5. Restartujemy telefon.

     

    NIE PRÓBOWAŁEM INSTALACJI PRZEZ TWRP.

    Telefon będzie uruchamiał się dłużej niż zwykle - nie przerywajmy tego procesu!

    Jeśli po pierwszym restarcie w Xposed Installer mamy monit o nieaktywnym frameworku wystarczy zrestartować telefon jeszcze raz, najlepiej zaznaczając przed tym jakiś moduł.

     

    Moduły kompatybilne z Oreo (osobiście je sprawdziłem):

     

    Źródło.

     

    Edytowane przez Kristyan
    usunięcie prefiksu z nazwą telefonu
    • Piwko! 2
    • Lubię to! 1

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Na G2 Mini miałem fajny moduł do wybudzania telefonu podwójnym "stuknięciem" w wyświetlacz, kojarzycie jak się nazywał i czy będzie działał na Oreo  ?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    paveu241

    @kkkamilll Oj, nie będzie to działało z A1. Na razie nie pewno nie. D2TW jest zaszyte w kernelu. Źródła już są, trzeba poczekać na jakiś custom kernel, który będzie to obsługiwał. Pytanie tylko, czy ekran też to obsługuje...

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Czyli nie ma modułu który by działał w ten sposób ?

     

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    paveu241

    @kkkamilll Jak napisałem wyżej - najpierw musi wspierać to wyświetlacz, później kernel. Żaden moduł, aplikacja czy inna modyfikacja nie uruchomi tego, jeśli oba warunki nie zostały spełnione.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Szanowni wiem, ze zbytnio nie w temacie, ale już któryś raz instaluje LineageOS i rożne xposed na podstawie rożnych opisów i zawsze mi się wysypuje :( czyli przy uruchomieniu jest aplikacja nie odpowiada. Zależy mi na module Phone Id Changer lub czymś podobnym.

    Jeśli jest tutaj ktoś ze stolicy i ma A1 w jednym placu to chętnie się gdzieś złapię na miescie i podrzucę za pomoc pakiecik bro lub buteleczkę %

    PM jak cos

     

     

    Edytowane przez Jaras77

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Perła

    Po wygraniu YouTube adaway nie działa aplikacja YouTube. 

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    paveu241
    11 godzin temu, Jaras77 napisał:

    Szanowni wiem, ze zbytnio nie w temacie, ale już któryś raz instaluje LineageOS i rożne xposed na podstawie rożnych opisów i zawsze mi się wysypuje :( czyli przy uruchomieniu jest aplikacja nie odpowiada.

    Pobierasz poprawną aplikację? 

    10 godzin temu, Perła napisał:

    Po wygraniu YouTube adaway nie działa aplikacja YouTube. 

    Bo YT adaway od dawna nie był aktualizowany. Albo musisz mieć wersję YT kompatybilną z adawayem, albo zainstaluj YT Vanced z Magisk Repo.

    • Lubię to! 1

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Perła

    Panowie, który framework wgrać. Wgrałem SDK 27, beta 3 i aplikacja SMS nie działa. Po odinstalowaniu, wszystko ok.

    dodana zawartość

    Problemem był mod MinMin Guard ustawiony na auto...

     

     

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    W dniu 1.08.2018 o 13:29, paveu241 napisał:

    Pobierasz poprawną aplikację?

    XposedInstaller_3.1.5-Magisk.apk to mój pierwszy tel z root wiec mogę coś źle robić.

     

    Ok chyba się udało zrobiłem cały system od nowa....

    ale niestety appka na której mi zależy nie działa i chciałbym prosić kogoś o sprawdzenie u siebie:

    https://play.google.com/store/apps/details?id=com.phoneinfo.changer

    u mnie aplikacja nie odpowiada, soft LOS 15.1

    Edytowane przez Jaras77

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Ostatnio przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.

    x