Skocz do zawartości
Kristyan

Odblokowanie bootloadera, TWRP i ROOT (Magisk)

    Rekomendowane odpowiedzi

    Jest temat na forum o tym. Poszukaj. Nawet chyba poradnik na YT.

    Problem polega na tym, że w fastboocie jest skopane wgrywanie obrazu. Zamiast komendy:

    fastboot boot twrp.img

    trzeba dać 

    fastboot flash recovery twrp.img

    i przejść potem do recovery.

     

    Wysłane z mojego 1+6 przy użyciu Tapatalka

     

    Z tegoż co wiem OP6 nie ma partycji recovery

    Więc zamiast komendy "fastboot flash recovery twrp.img" powinno być chyba "fastboot flash boot twrp.img"

     

    Dlatego zawsze bezpieczniej TWRP wgrywać za pomocą zip'a a nie img

     

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Kristyan

    No ja się teraz też męczę z tym trybem, instalacja komendą fastboot boot twrp.img nic nie daje, pokazuje się ten dziwny mode

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    kubatm

    @Kristyan - jest info o tym na Oxygen Updater w zakładce News, ale tutaj chodzi chyba o coś innego. w OB3 nie można wgrać recovery komendą taką jak zwykle bo spieprzyli otwieranie obrazu przez fastboot. 

    @bartolinio  - https://www.reddit.com/r/oneplus/comments/966moh/root_users_beware_issues_with_newer_twrp_versions/

    "These are the steps you'll need to do:

    • Make sure to download TWRP version 3.2.1-1 for your specific device. This is the version which worked fine, and is still fairly recent. 

    • Flash the version of TWRP using your method of choice. For fastboot users, connect your device to your computer in Fastboot mode and type fastboot flash recovery twrp-3.2.1-1-<yourdevice>.img. When using any of the flashing apps, browse to the correct TWRP.img file and flash it.

    • Reboot your device. You'll now be able to access the working version of TWRP

    • Do not update your TWRP version until it has been confirmed that this issue has been resolved."

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Kristyan

    @kubatm u mnie przy próbie wpisania "fastboot flash recovery twrp.img" pokazuje recovery no such partition.. wrrrrr 

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    kubatm

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Kristyan

    Z tego co zaobserwowałem udało mi się odpalić BluSpark TWRP. Zaraz próba flashowania OOS 9.0 i root

    https://forum.xda-developers.com/showpost.php?p=77628189&amp;postcount=438

    dodana zawartość

    OMG... Po instalacji zipa z OOS 9.0 zapomniałem że usuwa się TWRP, więc TWRP i roota znów nie ma. Jutro będę walczył dalej, teraz już sił brak :/

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    taxtor

    Dzięki, udało się wrócić do Oreo 8.1. Potem zaktualizowałem do Androida 9.0 stable. O to mi chodziło. Już dalej się nie bawię, to nie na moje nerwy...

    Najpierw chyba musisz się zastosować do tego ---> https://forum.android.com.pl/topic/350972-rozwiązany-włącza-się-tryb-awaryjny-qualcomm-po-przywracaniu-kopii-zapasowej-w-twrp/?tab=comments#comment-5444391 aczkolwiek być może pójdzie przejść od razu do kroku 2. 
     
     
    Kolega [mention=48814]bartolinio[/mention] poleca wgrać to TWRP, zaraz zresztą też siadam i aktualizuje do 9.0 stable.

    https://forum.xda-developers.com/devdb/project/dl/?id=30421 
    Najlepiej jak pobierzesz zmień sobie nazwę tego pliku na twrp.img, odpal fastboot 
    fastboot flash recovery twrp.img
    i potem przejdz do recovery, w recovery wgraj to https://forum.xda-developers.com/devdb/project/dl/?id=30420
     
    Jeśli się mylę to poprawcie [emoji4]


    Wysłane z mojego ONEPLUS A6003 przy użyciu Tapatalka

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Na oneplus'ach nie ma nerwów, te telefony są w zasadzie nie do ubicia [emoji16]

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    taxtor

    Tak też słyszałem, u mnie problem polega na tym że nigdy się w to nie bawiłem. Może kiedyś znowu spróbuję go zrootowac, ale szczerze mówiąc do szczęścia mi to nie jest wcale potrzebne [emoji14] Przynajmniej teraz wiem, że jak coś popsuje to potrafię go przywrócić potem do stanu używalności :)

    Na oneplus'ach nie ma nerwów, te telefony są w zasadzie nie do ubicia [emoji16]


    Wysłane z mojego ONEPLUS A6003 przy użyciu Tapatalka

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Czy ktoś też tak ma że w magisku SafetyNet jest poprawny , a w sklepie Play pokazuje się "urządzenie nie jest certyfikowane" oraz w aplikacjach do sprawdzania SafetyNet'u jest failed?

    Android 9.0 Stable
    Twrp bluespark
    Magisk v17.2

    Wysłane z mojego ONEPLUS A6003 przy użyciu Tapatalka

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Ostatnio przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.

    x